alexaandrov
3/29/2016 - 2:52 PM

1С пример кода

1С пример кода


&НаКлиенте
Функция РассчитатьПроцентНаценки(ЦенаЗакупки, ЦенаПродажи)
    ПроцентНаценки = 0;
    Если ЦенаЗакупки <> 0 Тогда
        ПроцентНаценки = (ЦенаПродажи - ЦенаЗакупки) * 100 / ЦенаЗакупки;
    КонецЕсли;  
    Возврат ПроцентНаценки;
КонецФункции    


&НаКлиенте
Процедура ПоследняяЦенаЗакупкиПриИзменении(Элемент)
    
    Объект.ПроцентНаценки = РассчитатьПроцентНаценки(Объект.ПоследняяЦенаЗакупки, 
                            Объект.ЦенаПродажи);
    
КонецПроцедуры

&НаКлиенте
Процедура ЦенаПродажиПриИзменении(Элемент)
    
    Объект.ПроцентНаценки = РассчитатьПроцентНаценки(Объект.ПоследняяЦенаЗакупки, 
                            Объект.ЦенаПродажи);
                             
КонецПроцедуры