epcim
10/21/2015 - 2:07 PM

redhat2fedora.howto.md

Change VM/OS from RHEL to FEDORA

change yum cfg

cd /etc
sudo cp yum.conf yum.conf.el6; cp -a yum yum.el6; cp -a yum.repos.d yum.repos.d.el6
sudo rm -rf yum.conf yum yum.repos.d
sudo cp yum.conf.fed yum.conf ; cp -a yum.fed yum; cp -a yum.repos.d.fed/ yum.repos.d

remove broken packages

sudo rpm -e --nodeps portaudio-19-9.fc12.i686 libgnome-keyring-devel-2.30.0-2.fc13.x86_64 libgcj-4.4.4-13.el6.x86_64 gnome-keyring-pam-2.30.1-2.fc13.x86_64 gmp-4.3.1-7.el6.i686
sudo rpm -e --nodeps portaudio-devel-19-9.fc12.i686                                         
sudo rpm -e --nodeps libgcj-devel-4.4.4-13.el6.x86_64 gnome-screensaver-2.28.3-8.el6.x86_64 
sudo rpm -e --nodeps gdm-2.30.4-21.el6_0.1.x86_64                                           

sudo yum --releasever 14 remove ibm-64bit-compat-6.00-6.el6.noarch compat-openldap-2.4.19_2.3.43-15.el6_0.2.x86_64 pyOpenSSL-0.10-2.el6.x86_64 system-config-display-2.2-1.el6.x86_64 control-center-standalone-2.28.1-28.el6.x86_64 gnome-libslab-2.30.0-2.el6.x86_64 iscsi-initiator-utils-6.2.0.872-10.el6.x86_64 application-browser-2.28.1-28.el6.x86_64 compat-openldap-2.4.19_2.3.43-15.el6_0.2.i686 lldpad-0.9.38-3.el6_0.2.x86_64 plymouth-theme-rings-0.8.3-17.el6.noarch python-cryptsetup-0.0.11-1.el6.x86_64 ibm-64bit-compat-6.00-6.el6.noarch gnome-main-menu-0.9.15-2.el6.x86_64
sudo yum --releasever 14 remove  iscsi-initiator-utils-6.2.0.872-10.el6.x86_64 kernel-module-nbd-2.6.32-71.24.1.1.el6.x86_64 generic-logos python-devel pyOpenSSL-0.10-2.el6.x86_64

upgrade

sudo yum --releasever 14 distro-sync --skip-broken
sudo yum --releasever 14 update
sudo yum --releasever 14 upgrade

some undocumented stuff here..

Some more packages was necessary to remove, Xorg failed to start due
incompatible fbdev and abi drivers. SOLVED by installing packages from LiveCD.

Remove system $RELEASEVER packages and install fedora ekvivalent

rpm -e --nodeps redhat-release-workstation-6Workstation-6.0.0.37.el6.x86_64
rpm -e --nodeps epel-release-6-5.noarch
rpm -Uvh --force --nodeps fedora-release-14-1.noarch.rpm

Upgrade to latest

sudo yum update
sudo yum upgrade