vishne0
6/9/2017 - 9:08 AM

Gentoo Blocks

Gentoo Blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.24.1-r2:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/perl-5.22.3_rc4:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/File-MimeInfo-0.270.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy ">=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_3(-),python_targets_python3_4(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-exec-9999::gentoo (masked by: missing keyword)

(dependency required by "dev-python/six-1.10.0::gentoo" [installed])
(dependency required by "dev-python/html5lib-0.9999999::gentoo" [installed])
(dependency required by "www-client/chromium-59.0.3071.86::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.